CoinStar service alert
Incident Report for SF Fire Credit Union
Resolved
The CoinStar machine is back in service. We thank you for your patience.
Posted Jul 17, 2018 - 07:54 PDT
Identified
The CoinStar machine is unavailable at this time.
Posted Jul 12, 2018 - 12:37 PDT