Loan Applications Online Banking
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Jul 20, 2018 - 14:29 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 20, 2018 - 14:28 PDT
Identified
Our Online Loan Application is currently undergoing emergency maintenance and is not accessible at this time. If you would like to apply for a loan, or inquire about a previous application, please reach out to our Contact Center. We apologize for any inconvenience.
Posted Jul 20, 2018 - 14:20 PDT
This incident affected: Online Services (Online & Mobile Banking).