California Street ATM is out of service..
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 15 days ago. Feb 06, 2019 - 10:24 PST
Update
ATM is still currently out of service. Expected to be out of service an additional 2-3 hours.
Posted 16 days ago. Feb 05, 2019 - 12:17 PST
Identified
California St. ATM will be out of service for 2 hours starting at 10:00 AM for software updates.
Posted 16 days ago. Feb 05, 2019 - 10:01 PST
This incident affected: California St. Branch (ATM).