Online Home Loan Applications is Currently Unavailable
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Mar 26, 2020 - 16:48 PDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 20, 2020 - 13:58 PDT
Identified
Our loan application site for Real Estate is experiencing a service interruption causing the site to be down.
Posted Mar 20, 2020 - 13:58 PDT
This incident affected: Online Services (Public Website).