Online Banking Degradation Of Services
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 16 days ago. Jan 02, 2019 - 15:59 PST
Investigating
We are currently experiencing degradation of services in our desktop and mobile banking platform. We are currently investigating the root cause. This may cause slow logins for our desktop and mobile banking platforms. We apologize for any inconvenience.
Posted 17 days ago. Jan 02, 2019 - 09:49 PST
This incident affected: Online Services (Online Banking (Web), Mobile Banking (iOS), Mobile Banking (Android)).