Mint Plaza Branch Temporarily Closed
Incident Report for SF Fire Credit Union
Update
We are continuing to monitor for any further issues.
Posted Jul 08, 2020 - 10:33 PDT
Monitoring
In light of reduced traffic at branches, and to protect the health of our members and employees, our Mint Plaza branch is temporarily closed. Our California Street and Stonestown branches are open normal hours Monday through Saturday, with continued Social Distancing requirements for all visitors.
Posted Jul 08, 2020 - 10:20 PDT
This incident affects: Mint Plaza Branch (CoinStar, Mint Plaza Lobby).