Stonestown's Coinstar is down
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 22 days ago. Jan 30, 2019 - 09:47 PST
Update
We are continuing to work on a fix for this issue.
Posted 29 days ago. Jan 23, 2019 - 15:43 PST
Identified
Stonestown coinstar is down, technician has been contacted. Will send update as soon as it is back up.
Posted 30 days ago. Jan 22, 2019 - 14:24 PST
This incident affected: Stonestown Branch (CoinStar).