California St. Coinstar is full.
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 03, 2019 - 08:14 PDT
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Apr 03, 2019 - 08:00 PDT
Identified
California St. Coinstar is full. We will update when issue is resolved and back working.
Posted 3 months ago. Apr 01, 2019 - 13:08 PDT
This incident affected: California St. Branch (CoinStar).