ATM (California St.) Maintenance
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 13:26 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2020 - 11:04 PST
Monitoring
We will be performing regular scheduled maintenance on the ATM listed. Access to the ATM may be limited or unavailable during this time. We apologize for the inconvenience.
Posted Nov 18, 2020 - 11:03 PST
This incident affected: California St. Branch (California ATM).