Online Banking Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 9 months ago. Feb 01, 2019 - 15:27 PST
Update
We are continuing to monitor for any further issues.
Posted 9 months ago. Feb 01, 2019 - 09:27 PST
Monitoring
Our digital banking partner is experiencing high user traffic across several financial institutions. Members may experience slower load times than normal. Our partner is actively monitoring network traffic to ensure optimal performance, we apologize for any inconvenience.
Posted 9 months ago. Feb 01, 2019 - 09:25 PST
This incident affected: Online Services (Online Banking (Web), Mobile Banking (iOS), Mobile Banking (Android)).