ATM (Mint Plaza) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 16, 2019 - 08:03 PDT
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Aug 14, 2019 - 11:05 PDT
Investigating
We are currently experiencing an issue with the ATM at our Mint Plaza branch. Access to this ATM may be limited or unavailable at this time. We apologize for the inconvenience.
Posted about 1 month ago. Aug 14, 2019 - 11:05 PDT
This incident affected: Mint Plaza Branch (ATM).