CoinStar (Stonestown) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 26, 2019 - 09:50 PDT
Update
We are continuing to work on a fix for this issue.
Posted 3 months ago. Mar 25, 2019 - 09:38 PDT
Identified
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted 3 months ago. Mar 25, 2019 - 09:25 PDT
This incident affected: Stonestown Branch (CoinStar).