Service Outage - Credit Card Rewards
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Jul 19, 2021 - 09:31 PDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2021 - 09:21 PDT
Investigating
We are investigating an issue that is affecting our Online and Mobile banking Credit Card Rewards service availability.
Posted Jul 19, 2021 - 09:14 PDT
This incident affected: Card Services (Credit Card Rewards).