The ATM at Mint Plaza is under maintenance and currently unavailable
Incident Report for SF Fire Credit Union
Resolved
ATM back up and running
Posted about 13 hours ago. Jan 18, 2019 - 09:53 PST
Update
We are continuing to investigate this issue.
Posted about 13 hours ago. Jan 18, 2019 - 09:43 PST
Investigating
We are currently investigating this issue
Posted 7 days ago. Jan 11, 2019 - 13:42 PST
This incident affected: Mint Plaza Branch (ATM).