CoinStar (Stonestown) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Jan 03, 2020 - 12:26 PST
Investigating
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted Jan 02, 2020 - 09:05 PST
This incident affected: Stonestown Branch (CoinStar).