Online Loan Applications Unavailable
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Oct 25, 2019 - 14:25 PDT
Update
We are continuing to investigate this issue.
Posted Oct 25, 2019 - 11:37 PDT
Investigating
Our online loan applications system is currently unavailable. We are working to correct the issue and apologize for the inconvenience. If you need assistance with a loan request, please reach out to our Contact Center.
Posted Oct 25, 2019 - 11:37 PDT
This incident affected: Online Services (Online & Mobile Banking).