Mobile Deposit Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 09:06 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2021 - 20:40 PST
Investigating
We are currently experiencing service issues with our Mobile Deposit feature. During this time you may experience slowness in depositing checks or the overall service being unavailable. We apologize or the inconvenience.
Posted Nov 17, 2021 - 19:35 PST
This incident affected: Online Services (Mobile Deposit).