Statement Outage Detected
Incident Report for SF Fire Credit Union
Resolved
Statement services have been restored.
Posted about 1 month ago. Aug 22, 2019 - 10:27 PDT
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Aug 22, 2019 - 09:36 PDT
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Aug 20, 2019 - 16:08 PDT
Investigating
We have detected an outage with our statement server and are currently investigating.
Posted about 1 month ago. Aug 20, 2019 - 14:28 PDT