Card Machine out of order
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted about 1 month ago. Apr 19, 2019 - 11:32 PDT
Monitoring
We are currently not able to print any Instant Issue cards. We are hoping to have service back up soon.
Posted about 1 month ago. Apr 19, 2019 - 10:24 PDT
This incident affected: Debit & Credit Cards (Orders & Reissues).