System Outage Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Mar 27, 2021 - 03:00 PDT
Investigating
We are currently experiencing a partial system outage. Some features in Online Banking may be unavailable at this time. We apologize for any inconvenience.
Posted Mar 26, 2021 - 17:30 PDT
This incident affected: Debit & Credit Cards (Activation) and Online Services (Online Banking (Web), Mobile Banking, Documents and Check Images).