Online banking message center is currently down
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Jan 08, 2021 - 13:50 PST
Update
We are continuing to work on a fix for this issue.
Posted Jan 08, 2021 - 09:38 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 08, 2021 - 09:37 PST
This incident affected: Online Services (Online Banking (Web)).