CoinStar (California St.) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Jan 08, 2020 - 09:17 PST
Identified
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted Jan 08, 2020 - 09:16 PST
This incident affected: California St. Branch (CoinStar).