Service Interruption for Mobile Deposit
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 29 days ago. Jun 21, 2019 - 15:52 PDT
Investigating
We are currently experiencing intermittent interruptions in service impacting the response time for Mobile Deposit. We apologize for the inconvenience.
Posted 29 days ago. Jun 21, 2019 - 11:28 PDT
This incident affected: Online Services (Mobile Banking (iOS), Mobile Banking (Android)).