CoinStar (Mint Plaza) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Oct 21, 2019 - 07:12 PDT
Identified
The CoinStar machine at our Mint Plaza branch is unavailable at this time. We apologize for the inconvenience.
Posted Oct 19, 2019 - 11:20 PDT
This incident affected: Mint Plaza Branch (CoinStar).