Service Outage - Fax Line For Wire Requests
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Sep 16, 2020 - 14:05 PDT
Investigating
Our fax line for wire requests is temporarily out of service (415-358-4901). We are currently investigating the issue. In the meantime please submit remote wire requests via the online banking message center, or via Fax @ 415-674-4691
Posted Sep 16, 2020 - 10:33 PDT