Instant issue debit/credit card machine undergoing maintenance
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 17, 2019 - 13:01 PDT
Investigating
The instant issue debit/credit card machine at our California branch is undergoing maintenance and unavailable until further notice
Posted 6 months ago. Apr 16, 2019 - 17:17 PDT
This incident affected: Debit & Credit Cards (Orders & Reissues).