Coinstar (Stonestown) Service Alert
Incident Report for SF Fire Credit Union
Resolved
The CoinStar machine at our Stonestown branch is now operational.
Posted 24 days ago. Jun 26, 2019 - 15:01 PDT
Identified
The Coinstar machine at our Stonestown branch is unavailable at this time. We apologize for the inconvenience.
Posted 26 days ago. Jun 24, 2019 - 12:02 PDT
This incident affected: Stonestown Branch (CoinStar).