Response Time for Internal Systems
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Dec 01, 2023 - 12:45 PST
Investigating
We are currently investigating slow load times in some of our internal tools. This may impact our support staff as they try to assist members this morning. We are actively engaged on the issue and hope to resolve it as soon as possible. We thank you for your patience this morning.
Posted Dec 01, 2023 - 08:27 PST
This incident affected: Contact Center (Phone Support, Web Chat).