Online Banking Outage

Incident Report for SF Fire Credit Union

Resolved

We’re happy to report that the issue affecting online and mobile banking has been resolved. We will continue to closely monitor systems to ensure services remain stable. If you experience any additional issues, please don’t hesitate to contact us.

Thank you for your patience and understanding.
Posted May 05, 2026 - 18:30 PDT

Investigating

Online and Mobile Banking services are currently unavailable. We are actively working to resolve the issue and will share updates as soon as possible. We apologize for any inconvenience.
Posted May 05, 2026 - 17:18 PDT
This incident affected: Online Services (Online & Mobile Banking, Money Movement).