Mobile Deposit Outage
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 11, 2019 - 08:38 PDT
Investigating
We are currently experiencing an outage that is affecting all shared branch transactions as well as mobile deposit. Our teams are actively working to resolve this issue.
Posted 2 months ago. Jul 10, 2019 - 16:24 PDT
This incident affected: Online Services (Mobile Banking (iOS), Mobile Banking (Android)).