Online Banking Outage
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Mar 10, 2021 - 10:01 PST
Investigating
We are investigating an outage with our Online & Mobile Banking platform, and will provide updates as soon as possible. We apologize for any inconvenience.
Posted Mar 10, 2021 - 09:58 PST
This incident affected: Online Services (Online & Mobile Banking, Money Movement).