Phone and Chat Performance issue
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 14:11 PST
Investigating
Our phone and chat services are currently unavailable.
Online and Mobile Banking are available. Please send us a message using the message center with any assistance you need.
We apologize for the inconvenience and are working to restore services as soon as possible.
Posted Mar 05, 2024 - 12:17 PST
This incident affected: Contact Center (Phone Support, Web Chat).