Mobile Deposit & Zelle Outage

Incident Report for SF Fire Credit Union

Resolved

The service disruptions affecting debit and credit cards, mobile deposit, Zelle®, and shared branch transactions have been resolved. We appreciate your patience.
Posted Oct 22, 2025 - 17:31 PDT

Investigating

We’re currently experiencing service disruptions affecting debit and credit cards, mobile deposit, Zelle®, and shared branch transactions. Our teams are working to restore full service as quickly as possible. We will provide updates to this alert as we receive them and apologize for the inconvenience.
Posted Oct 22, 2025 - 14:08 PDT
This incident affected: Online Services (Mobile Deposit).