CoinStar (California St.) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Sep 02, 2020 - 15:24 PDT
Identified
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted Sep 01, 2020 - 16:37 PDT
This incident affected: California St. Branch (CoinStar).