Pacifica Branch Power Outage
Incident Report for SF Fire Credit Union
Resolved
Power has been restored at our Pacifica branch, and normal operations will resume during normal business hours.
Posted 5 months ago. Mar 12, 2019 - 18:46 PDT
Identified
Pacifica Branch is currently experiencing a power outage. We apologize for any inconvenience. We will update once the power is back on.
Posted 5 months ago. Mar 12, 2019 - 15:59 PDT
This incident affected: Pacifica Branch.