Online Loan Applications Unavailable
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Jun 09, 2022 - 13:13 PDT
Identified
Our online loan applications system is currently unavailable. We are working to correct the issue and apologize for the inconvenience. If you need assistance with a loan request, please reach out to our Contact Center.
Posted Jun 09, 2022 - 12:56 PDT
This incident affected: Online Services (Online Account Opening).