CoinStar (California St.) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Dec 02, 2019 - 07:59 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 26, 2019 - 12:07 PST
Identified
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted Nov 25, 2019 - 15:29 PST
This incident affected: California St. Branch (CoinStar).