CoinStar (Mint Plaza) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 12 days ago. Jun 04, 2019 - 12:17 PDT
Investigating
The CoinStar machine at our Mint Plaza branch is unavailable at this time. We apologize for the inconvenience.
Posted 13 days ago. Jun 03, 2019 - 10:19 PDT
This incident affected: Mint Plaza Branch (CoinStar).