ATM (California St.) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Jan 09, 2020 - 11:46 PST
Investigating
We are currently experiencing an issue with the ATM at our California Street branch. Access to this ATM may be limited or unavailable at this time. We apologize for the inconvenience.
Posted Jan 06, 2020 - 09:11 PST
This incident affected: Mint Plaza Branch (Mint Plaza Lobby).