Online Banking Outage
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 25 days ago. May 22, 2019 - 17:38 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 25 days ago. May 22, 2019 - 17:20 PDT
Investigating
We are investigating an outage with our Online & Mobile Banking platform, and will provide updates as soon as possible. We apologize for any inconvenience.
Posted 25 days ago. May 22, 2019 - 16:58 PDT
This incident affected: Online Services (Online Banking (Web), Mobile Banking (iOS), Mobile Banking (Android)).