Online Loan Application (CUDL) will be unavailable 7:00AM - 8:30AM Thursday, 1/31/19
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 31, 2019 - 08:19 PST
Monitoring
Online Loan Application (CUDL) will be unavailable 7:00AM - 8:30AM Thursday, 1/31/19 due to scheduled maintenance.
Posted 3 months ago. Jan 30, 2019 - 17:48 PST
This incident affected: Online Services (Online Banking (Web), Mobile Banking (iOS), Mobile Banking (Android)).