CoinStar (Mint Plaza) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Jan 07, 2020 - 12:29 PST
Identified
The CoinStar machine at our Mint Plaza branch is unavailable at this time. We apologize for the inconvenience.
Posted Jan 06, 2020 - 08:40 PST
This incident affected: Mint Plaza Branch (CoinStar).