CoinStar (Mint Plaza) Service Alert
Incident Report for SF Fire Credit Union
Resolved
Coinstar is back in service.
Posted 3 months ago. May 01, 2019 - 08:50 PDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Apr 29, 2019 - 08:59 PDT
Investigating
The CoinStar machine at our Mint Plaza branch is unavailable at this time. We apologize for the inconvenience.
Posted 3 months ago. Apr 27, 2019 - 09:38 PDT
This incident affected: Mint Plaza Branch (CoinStar).