California St. ATM unavailable Thursday 01/24/2019
Incident Report for SF Fire Credit Union
Resolved
Our California Street ATM is back in service.
Posted about 2 months ago. Jan 25, 2019 - 09:09 PST
Update
Our California Street ATM is out of service due to a scheduled upgrade. We apologize for the inconvenience.
Posted about 2 months ago. Jan 24, 2019 - 16:35 PST
Investigating
The ATM at the California St. Main Branch will be under repair on Thursday 1/24 from approximately 7am-11am.
Posted about 2 months ago. Jan 23, 2019 - 17:23 PST
This incident affected: California St. Branch (ATM).