Increased Bill Pay Response Time
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Apr 01, 2020 - 15:04 PDT
Investigating
Our bill pay provider is currently experiencing degraded performance of their system, which may cause members to be unable to access online bill pay functionality at this time. Our vendor is aware of the issue and working to resolve the issue. We apologize for any inconvenience at this time.
Posted Apr 01, 2020 - 08:15 PDT
This incident affected: Online Services (Online Banking (Web), Mobile Banking (iOS), Mobile Banking (Android)).