Alkami degradation of service
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted 4 days ago. Jun 12, 2019 - 17:18 PDT
Investigating
Members may experience a "Technical Difficulties" page when trying to access, we are currently investigating a fix.
Posted 4 days ago. Jun 12, 2019 - 16:50 PDT
This incident affected: Online Services (Online Banking (Web)).