Online & Mobile Banking Response Time
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Jan 01, 2023 - 20:28 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 01, 2023 - 19:33 PST
Investigating
We are investigating an issue with the response time of our Online & Mobile Banking platform. Some services may be intermittently affected, and we will provide updates as soon as possible. We apologize for any inconvenience.
Posted Jan 01, 2023 - 19:32 PST
This incident affected: Online Services (Online & Mobile Banking).