Mint Plaza branch is currently undergoing maintenance and unavailable
Incident Report for SF Fire Credit Union
Resolved
Our Mint Plaza ATM is now operational.
Posted 14 days ago. Oct 09, 2019 - 08:41 PDT
Update
We are continuing to monitor for any further issues.
Posted 14 days ago. Oct 09, 2019 - 08:40 PDT
Monitoring
Mint Plaza branch is currently undergoing maintenance and unavailable
Posted 16 days ago. Oct 07, 2019 - 11:41 PDT
This incident affected: Mint Plaza Branch (ATM).