CoinStar (California St.) Service Alert
Incident Report for SF Fire Credit Union
Resolved
This incident has been resolved.
Posted Jan 31, 2020 - 14:45 PST
Identified
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted Jan 29, 2020 - 11:29 PST
This incident affected: California St. Branch (California CoinStar).