CoinStar (Stonestown) Service Alert
Incident Report for SF Fire Credit Union
Resolved
Coinstar is currently back in service.
Posted 6 months ago. Feb 25, 2019 - 10:36 PST
Investigating
The CoinStar machine is unavailable at this time. We apologize for the inconvenience.
Posted 6 months ago. Feb 23, 2019 - 14:56 PST
This incident affected: Stonestown Branch (CoinStar).